Latest WordPress Vulnerabilities

Latest WordPress Vulnerabilities

Here is a list of some the latest WordPress Vulnerabilities provided by cvedetails.com.
This list is by no means a complete list of known vulnerabilities or exploits but it comes from a well respected source.

The score is rated from 0 (low risk) to 10 (extreme risk).

  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to lack of proper sanitization in one of the classes, there's potential for unintended SQL queries to be executed. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 4.1.34. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.,
    CVE ID CVE-2022-21664, CWE ID 89,
    Score [ 6.5, ]
    Published Date: 2022-01-06, Updated: 2022-04-12,
    more info here


  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. On a multisite, users with Super Admin role can bypass explicit/additional hardening under certain conditions through object injection. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.,
    CVE ID CVE-2022-21663, CWE ID 74,
    Score [ 6.5, ]
    Published Date: 2022-01-06, Updated: 2022-04-12,
    more info here


  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Low-privileged authenticated users (like author) in WordPress core are able to execute JavaScript/perform stored XSS attack, which can affect high-privileged users. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this issue.,
    CVE ID CVE-2022-21662, CWE ID 79,
    Score [ 3.5, ]
    Published Date: 2022-01-06, Updated: 2022-04-12,
    more info here


  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MariaDB database. Due to improper sanitization in WP_Query, there can be cases where SQL injection is possible through plugins or themes that use it in a certain way. This has been patched in WordPress version 5.8.3. Older affected versions are also fixed via security release, that go back till 3.7.37. We strongly recommend that you keep auto-updates enabled. There are no known workarounds for this vulnerability.,
    CVE ID CVE-2022-21661, CWE ID 89,
    Score [ 5.0, ]
    Published Date: 2022-01-06, Updated: 2022-04-12,
    more info here


  • Summary:WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.,
    CVE ID CVE-2021-44223, CWE ID 0,
    Score [ 7.5, ]
    Published Date: 2021-11-25, Updated: 2021-11-30,
    more info here


  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions authenticated users who don't have permission to view private post types/data can bypass restrictions in the block editor under certain conditions. This affected WordPress 5.8 beta during the testing period. It's fixed in the final 5.8 release.,
    CVE ID CVE-2021-39203, CWE ID 863,
    Score [ 6.0, ]
    Published Date: 2021-09-09, Updated: 2021-09-24,
    more info here


  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions the widgets editor introduced in WordPress 5.8 beta 1 has improper handling of HTML input in the Custom HTML feature. This leads to stored XSS in the custom HTML widget. This has been patched in WordPress 5.8. It was only present during the testing/beta phase of WordPress 5.8.,
    CVE ID CVE-2021-39202, CWE ID 79,
    Score [ 3.5, ]
    Published Date: 2021-09-09, Updated: 2021-09-24,
    more info here


  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress),
    CVE ID CVE-2021-39201, CWE ID 79,
    Score [ 3.5, ]
    Published Date: 2021-09-09, Updated: 2021-12-14,
    more info here


  • Summary:WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions output data of the function wp_die() can be leaked under certain conditions, which can include data like nonces. It can then be used to perform actions on your behalf. This has been patched in WordPress 5.8.1, along with any older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.,
    CVE ID CVE-2021-39200, CWE ID 200,
    Score [ 4.3, ]
    Published Date: 2021-09-09, Updated: 2021-12-14,
    more info here


  • Summary:WordPress is an open source CMS. One of the blocks in the WordPress editor can be exploited in a way that exposes password-protected posts and pages. This requires at least contributor privileges. This has been patched in WordPress 5.7.1, along with the older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.,
    CVE ID CVE-2021-29450, CWE ID 200,
    Score [ 4.0, ]
    Published Date: 2021-04-15, Updated: 2021-04-23,
    more info here